Service Degradation Notice – Ongoing Heroku Infrastructure - Router Issue
Resolved
Jul 23, 2025 at 2:07pm UTC
This has been resolved as me moved the infra to AWS.
Affected services
Updated
Jul 22, 2025 at 12:52pm UTC
Any news on this?
Affected services
Created
Jul 21, 2025 at 12:58pm UTC
Dear Customer,
Our infrastructure provider, Heroku, is currently facing issues that are causing degraded performance on Chatwoot. A disproportionate number of requests are being routed to a few dynos, resulting in performance bottlenecks.
We believe this is related to Heroku’s recent switch to HTTP/2 router on July 17, 2025.
We apologize for the inconvenience and appreciate your patience. Our team is actively monitoring the situation and working on a migration to resolve this.
Affected services