Back to overview
Resolved
Service Degradation Notice: Delays in message delivery
Nov 13, 2025 at 8:39pm UTC
Affected services
Application (Dashboard & API)
Resolved
Nov 14, 2025 at 2:47am UTC
Closed as the issues are resolved.
Affected services
Created
Nov 13, 2025 at 8:39pm UTC
We’re currently experiencing delays in message delivery across some conversations. Our team is actively investigating the root cause and working to restore normal performance.
We’ll share another update as soon as we have more information. Thank you for your patience.
Affected services