Back to overview
Resolved

Service Degradation: Email Delivery Disruption

Jul 20, 2026 at 4:19am UTC
Affected services
Application (Dashboard & API)
Message Delivery & Automations
Email

Resolved
Jul 20, 2026 at 1:25pm UTC

This incident has been resolved, and email delivery is operating normally. We are continuing to monitor the infrastructure closely.

Any emails that failed to send during the disruption are being automatically retried.

Created
Jul 20, 2026 at 4:19am UTC

We're currently experiencing an upstream service disruption with our email provider. As a result, email delivery may be impacted for Email Channels using Custom Email Domains, as well as automated emails such as invitations and password reset emails.

Our team is actively working with our provider to resolve the issue as quickly as possible. We apologize for the inconvenience and will provide updates as more information becomes available.